Service Degradation due to AWS outage

Incident Report for Summation Status

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:43 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 18:33 UTC

Investigating

The following services have been impacted due to site-wide AWS outage in us-east-1 region:


Okta third-party integration: https://status.okta.com/
Stytch SAML integration: https://status.stytch.com/
We are actively monitoring these integration points for quick recovery.
Posted Oct 20, 2025 - 17:47 UTC
This incident affected: API and Application.